Recent Posts

Pages: [1] 2 3
1
Nissan / Nissan Navara 4lt v6 Fixing Faulty Ignition Coils
« Last post by peter on May 20, 2016, 08:08:47 PM »
Navara came into the workshop with a engine idles roughly and and when you accelerate the engine jerks. I do suspect the ignition coils, a diagnose test show nothing. I pull out the coils and test them with a coil tester. All six were apparently cracked just below the coil it self. The coils work perfectly but because of these tiny cracks the park will jump out to the metal side of the engine. The spark plugs are fiitted deep into the cylinderhead so the spark has to travel down to the plug.  If this happen to your car coils you can use a rubber pipe, cut short peaces and pull them over the bottom part of the coil to insulate the coil's barrel/tube as far as possible.
See the video below, this tip work quite good, the coils might be working perfectly for a long time





2
Polo Tdi 1900 water pump / Polo 2011 vivo 1400 - diagnose codes P0302 and P0300
« Last post by peter on April 04, 2016, 06:30:16 PM »
This car problem was that the engine idles roughly and it performs very bad, goes in limb mode. I have pulled codes from the ECU and got the following:
Cylinder 2
P0302 - 000 - Misfire Detected - Intermittent
Freeze Frame:
Fault Status: 00100000
Fault Priority: 2
Fault Frequency: 2
Reset counter: 6
Time Indication: 0
Freeze Frame:
Bin. Bits: 00000100
Load: 100.0 %
Lambda: 0.0 %
Speed: 60.0 km/h
Temperature: 46.0°C
Absolute Pres.: 796.3 mbar
RPM: 2250 /min
16684 - Random/Multiple Cylinder Misfire Detected
P0300 - 000 - - Intermittent
Freeze Frame:
Fault Status: 00100000
Fault Priority: 1
Fault Frequency: 1
Reset counter: 7
Time Indication: 0

Now this could be as follows:
1.Plug dead at no 2 piston
2.Ignition coil faulty Piston 2
3.Injector no 2 - faulty

I have remove the plug from no 2 and it is completely black, not wet black but pitch black, this indicates that this piston is over fueling. I have done a coil test and it test fine.  Now to enable me to really pin point the problem  I have change injector 2 with no 4 and ask the customer to bring the car back after a day or so.  After customer brought back the car with same problems I have pulled codes from the ECU again and just look at the results
16688 - Cylinder 4
            P0304 - 000 - Misfire Detected - Intermittent
             Freeze Frame:
                    Fault Status: 00100000
                    Fault Priority: 2
                    Fault Frequency: 28
                    Reset counter: 0
                    Time Indication: 0

             Freeze Frame:
                    Bin. Bits: 00000100
                    Load: 100.0 %
                    Lambda: 0.0 %
                    Speed: 64.0 km/h
                    Temperature: 86.0°C
                    Absolute Pres.: 795.6 mbar
                    RPM: 3556 /min
Now the problem is at no 4 piston, this definitely indicates the injector is faulty
Hopes this helps
3
BMW / BMW X5 4.4 2008 - DIAGNOSE CODES P1055 AND P1058
« Last post by peter on March 11, 2016, 06:09:19 PM »
This vehicle came in with customer complains that the engine go in limp mode, all light go on at the dashboard, like abs, brakes, 4x4 , engine failure, gearbox failure  etc. I have got some obd2 fault codes from the ECU P1055 and P1058 - these codes have something to do with the vvt motor. I was not happy with these codes so I did some more test, after awhile I found that the alternator is not charging, it was charging at a rate of 12.5 volts, this is well below the charging rate of at least 14.00 volts. The battery light at the dashboard did not give any warning that the alternator was not charging. It was on when the ignition key was turn on and after the engine started the light go off, it looks normal, but for such expensive car , the light does not work properly. In older cars the battery light will stay on if there is something wrong with the alternator.

After testing with a volt meter I determined that the alternator is not charging. The alternator regulator was faulty

Hope this will help someone else with the some problem.
 
4
Volkswagen Polo / Polo Classic 1600 2006 ignition coil problems
« Last post by peter on November 17, 2015, 07:08:10 PM »
If your Polo (petrol) ever give you problems by not starting sometimes or the car is jerking. One of the problems could  be your ignition coil. I have two videos which show how the spark is jumping out of the coil's barrel's side instead of going to the mouth where the plug lead is plug into.


5
Audi A4 1800 / Audi A4 20TDI 2005 CAMBELT TIMING MARKS
« Last post by peter on August 26, 2014, 11:28:26 AM »
If ever you want to know the cambelt timing marks of the Audi A4 20tdi, look at the attached photos. On the photos
are red arrows which indicate the marks.



Look at the red arrows, the marks must align according to the arrows.


I have used a bolt and a allen key to hold the cam pulleys in position.
6
Renault Megane / Renault Megane 16.00 16v idling Cutout Problem
« Last post by peter on February 03, 2014, 04:22:39 PM »
The other day I had  a RENAULT MEGAN 1600 16V Customer complaint that the
car is cutting out when she go around a corner or when she approach a red light. or stop street.
She could start the engine immediately and would go on without any troubles.

I took the car for a test drive and found that the car is not pulling strong, as if one of the
ignition coils is not firing. There is a lack of power. The engine would sometimes cut out at
stop street or if one go around the corner. Pulling away also was not smoothly.

To cure the problem I have done the following:
1. I have removed the ignition coils and test them on a tester , they test all OK
2. Test the fuel pressure it is OK.
3. The next thing I have done was, I noticed that the MAP (manifold absolute pressure) was very loosely,
    as if the "o" rings were worn. I tried removed the MAP sensor but the front part broke of and I had to
    remove the front part from the intake manifold. Once I got it out I use super glue to reassemble
    the front part  to the MAP body.
 4. Diagnose test show no codes, so this makes it more difficult.   

I took the car for a test drive and it performed much better, the engine is not cutting out anymore and
performance is back to normal.

The MAP sensor must have been cracked just above the "o" rings causing the engine to cut out and
cause the engine to perform poorly.

7
Jetta4 2lt / Jetta4 2lt daignose Faults 17536 P1128
« Last post by peter on May 20, 2013, 04:27:54 PM »
The above mentioned Jetta diagnose report is as follows:

17536 P1128   Bank1,Mixture adaption air (mult.) System too lean
  Open circuit
 16684 P0300   Misfiring recognized
  Open circuit
 16687 P0303   Cyl.3 Misfiring recognised
  Open circuit
 16685 P0301   Cyl.1 Misfiring recognised
  Open circuit
 16686 P0302   Cyl.2 Misfiring recognised
  [SP]
  Open circuit
 16684 P0300   Misfiring recognized
  [SP]
  Open circuit
 16685 P0301   Cyl.1 Misfiring recognised
  [SP]
  Open circuit
 16686 P0302   Cyl.2 Misfiring recognised
  [SP]
  Open circuit
 16687 P0303   Cyl.3 Misfiring recognised
  [SP]
  Open circuit
 16688 P0304   Cyl.4 Misfiring recognised
  Open circuit
 16688 P0304   Cyl.4 Misfiring recognised
  [SP]
  Open circuit
 16518 P0134   Bank1-Probel No activity
  [SP]
  Open circuit

I have done the following tests:
1.Remove the ignition coil and test it with a coil tester - test faulty.
2.Check the fuel pressure - test Ok 25 - 30 kpa
3.Check the Air temp/Maf sensor the a ohm meter - it is within the specs.

The problem with this car was, the engine lack power, if you try to rev it , it will only rev up to about 2500rpm. Before buying a new Air temp/maf sensor , I have remove it from the airbox and clean it with carb cleaner.
This cure the problem, now since I have clean the Air sensor and replace the ignition coil and Plug wires, this
car is running excellent.

The customer is now very happy


8
Audi A4 1800 / Audi A4 1800 Diagnose faults: 8001/P1593/005523
« Last post by peter on May 20, 2013, 04:12:10 PM »
I had a Audi A4 1800 who gave me the following diagnose faults: 8001/P1593/005523 - Altitude Adaptation: Signal Out of Tolerance
Possible Symptoms

    Unknown

Commentary

This is one of those fault codes where the ECU knows something is amiss, but cannot pinpoint the cause.
Possible Causes


    MAF sensor (G70) out of tolerance.
    Leak in intake system.
    Throttle position sensors (G187/G188) out of tolerance.

Possible Solutions

    Check MAF/replace MAF Sensor (G70).
    Check intake systems for leaks and repair.
    Check Throttle position sensors (G187/G188).

As you can see the Ecu cannot pin point the problem, But what I have done is I have replaced
the MAF sensor and this cure the problem.
9
If ever you want to install front wheel bearings for a Honda Jazz and you have the right tools to do it. Proceed with the followings tips:
1. Remove the wheel bearing from the front stub axle
2.Buy the right bearing - one with the magnetic seal for ABS -
   The car ABS will not work if you fit the wrong bearing.
3.Fit the bearing with the magnetic seal towards the sensor, The bearing side   with the magnetic seal must go in first into the stub axle, close to the sensor.
4.Make sure there is no signs of damaged to the sensor.

To determine which side of the bearing has the magnetic seal, get a small round metal ball -size about 3mm, or anything thing small. See the attached image for a example. The red arrow point to the small metal ball which is  attracted with magnetic force.

The bearing other side will not attract the metal ball.



10
Kia Sorento 2.5td diagnose fault p1188 / Kia Sorento 2.5td diagnose fault p1188
« Last post by peter on February 25, 2013, 02:57:13 PM »
If you have a Sorento 2.5td and you experience that the car/engine cuts out sometimes especially when you accelerate.  The engine warning light comes on at the same time. You have to wait a minute or so, you can restart the vehicle and the car will go on ok for a while. This article will help you. If you have a scanner and the fault code is P1188, then this code stands for "Fuel pressure Leakage" There is a pressure drop and the sensor pick it up and to protect the engine the ECU cut off the engine.

This fault code refer to a few problems:
1.Dirt in the fuel tanks
2.Fuel lines damaged/leaking
3.Dirty Diesel filter
4.Pressure regulator valve faulty.
5.Injectors  -  maybe?
6.Diesel pump faulty.

To start from a point, go to the fuel tank first. Fortunately this car got an inspection hole under the rear seat. Remove the cover plate and then you will see the fuel tank unit, just remove the pipes and then the unit. I was lucky, the car I was inspecting, after removing the fuel tank sensor unit, I noticed the pick up pipe's sieve was block with dirt - see attached image. You have to open this unit, because after I have open the unit I found more dirt inside - see attached image.

Inspect the  tank as well for any dirt.  I have clean everything and replaced the fuel filter. This cure the problem. If in your case, you find there is no dirt , then inspect all fuel lines/filter.  I would next check fuel pressure/fuel pressure sensor and the pump.

Hope this helps.
Pages: [1] 2 3
Visit Our Auto Parts Store
**********************
Trailer Tester